Degraded backup performance

Incident Report for m113

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 07:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 01:38 UTC

Investigating

We are currently experiencing degraded backup performance that may affect backup SLAs for some customers. Our engineering team is actively investigating the root cause and taking steps to resolve the issue as quickly as possible.
Posted Apr 09, 2026 - 13:18 UTC
This incident affected: Web Portal (Central India) and Office 365 (Central India).